This mailer was sent out on Thursday 12 May at 17:45 (CAT)


View Mailchimp Mailer


If you are using a Peach plugin (Shopify, WooCommerce and/or Wix) please ignore this notification.

If you have a custom integration using our Copy and Pay, and/or server-to-server, and/or our Mobile SDK API please implement the Payments Association of South Africa (PASA) mandated changes outlined below.



Dear Merchant,


At Peach Payments, we strive to continuously provide world-class, leading payments infrastructure that offers a secure and seamless experience for our merchants and their customers.


One of the major initiatives that we are currently undertaking (in line with global payment standards) is switching over our merchants to the VISA and Mastercard mandated 3D Secure Version 2 authentication flow.


This mandated switchover requires our merchants to implement certain changes to their API calls before the end of June 2022 which are outlined below:


Why is this now a requirement?


  • With the rapid growth of eCommerce and the subsequent increase in volumes of stored card transactions, VISA and Mastercard have rolled out new mandates which pertain to how cardholders’ payment credentials (i.e. account details) are stored for future purchases.

  • Part of this mandate includes the switch to 3D Secure 2 (3DS2) Security Protocol


 

What action is required from You/The Merchant?




Deadline - while the deadline is June 2022, the longer the merchant takes to implement, the higher likelihood of receiving chargebacks. 

 

Thank You for using Peach Payments as a Payment Gateway and please do not hesitate to reach out to us if you have any questions.


Peach Payments Support


Contact us at support@peachpayments.com